logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
cyracks  
#1 Posted : Friday, June 5, 2020 11:40:41 PM(UTC)
cyracks

Rank: Member

Groups: Registered
Joined: 6/5/2020(UTC)
Posts: 11
Slovenia

Thanks: 3 times
Hello,

I would like to test SealReport, but I am having some problems with IIS. How can I fix error bellow:

Detailed Error Information:
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070021
Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File \\?\C:\inetpub\wwwroot\Seal Report\web.config


ps: you should really write more detail information on how to install/configure IIS.

Thanks for the help.
epf  
#2 Posted : Saturday, June 6, 2020 6:15:39 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 915
Switzerland

Thanks: 14 times
Was thanked: 153 time(s) in 147 post(s)
Normally, publication on IIS is quite easy using the Wizard of the Server Manager:
Check
https://sealreport.org/#lineCompilation

If you have a previous installation, you may remove the previous web.config before re-publishing...or start from a clean folder

Edited by user Saturday, June 6, 2020 6:16:49 AM(UTC)  | Reason: Not specified

cyracks  
#3 Posted : Sunday, June 7, 2020 8:28:59 AM(UTC)
cyracks

Rank: Member

Groups: Registered
Joined: 6/5/2020(UTC)
Posts: 11
Slovenia

Thanks: 3 times
Hello,

thanks for the help, I did the following:
1) Install Seal Reports
2) Install IIS with Application Development (some picture of install options would be helpful)
3) Open Seal Report designer and created dummy report
4) Open Seal Server Manager -> Configuration -> Publish Web Site on IIS -> Publish files and site
Starting web site publishing
...
Web site has been published successfully..


5) Close form -> do you want to try it now -> Yes

Internal Server Error is shown

ps: IIS was not used before and I have a clean install of windows server 2019 standard (trial)

Regards,
Tomaž
cyracks  
#4 Posted : Monday, June 8, 2020 12:18:24 AM(UTC)
cyracks

Rank: Member

Groups: Registered
Joined: 6/5/2020(UTC)
Posts: 11
Slovenia

Thanks: 3 times
Just for the record, if I try to install on Windows 10 it works ok so there must be some default restriction in windows server 2019.
epf  
#5 Posted : Monday, June 8, 2020 6:15:14 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 915
Switzerland

Thanks: 14 times
Was thanked: 153 time(s) in 147 post(s)
Yes, the wizard has not been tested on Windows 2019 Server, can you find out what configuration is missing so we can update the Wizard for the future releases.
Are you using the .NET Core distribution or the standard .Net ?

you can google "windows 2019 Module IIS This configuration section cannot be used at this path" to have clue.

Thanks.
cyracks  
#6 Posted : Sunday, June 21, 2020 7:51:25 PM(UTC)
cyracks

Rank: Member

Groups: Registered
Joined: 6/5/2020(UTC)
Posts: 11
Slovenia

Thanks: 3 times
Hello,

I can not fix the error, if you want I can give you access to the computer so you can check yourself (it is clean a demo install). E-mail me for login info.

Regards,
Tomaž
epf  
#7 Posted : Monday, June 22, 2020 1:27:13 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 915
Switzerland

Thanks: 14 times
Was thanked: 153 time(s) in 147 post(s)
Thank you, I will contact you next week.
epf  
#8 Posted : Wednesday, July 1, 2020 2:52:24 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 915
Switzerland

Thanks: 14 times
Was thanked: 153 time(s) in 147 post(s)
After a quick check, you have to install the following IIS Role:
Web Server -> Application Development -> AP.Net 4.7

After this publishing with the wizard works fine...
thanks 1 user thanked epf for this useful post.
cyracks on 7/1/2020(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.