logo
Welcome Guest ! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Khushii  
#1 Posted : Monday, July 31, 2023 12:52:43 PM(UTC)
Khushii

Rank: Newbie

Groups: Registered
Joined: 7/26/2023(UTC)
Posts: 4
Canada

Thanks: 2 times
I'm using seal report web server to display my seal report on screen. As it is using real time data so I refresh the data after every 15 mins. It works fine for 1 day but after that it shows "The report is not in your session anymore" and when I execute the report it automatically logs out. So, is there a way that I can set it to never log out ?
epf  
#2 Posted : Monday, July 31, 2023 1:47:39 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 1,208
Switzerland

Thanks: 14 times
Was thanked: 205 time(s) in 198 post(s)
difficult to say, check in the Event Viewer why the session is lost,
often it is because the Web Report Server is restarted through IIS.
check the options in your Application Pool Advanced Settings (Idle Timeout and Recycling Options)
You may also try to change the ASP Session timeout in your appsettings.json.

I guess your application pool is being recycled every day.
thanks 1 user thanked epf for this useful post.
Khushii on 7/31/2023(UTC)
Khushii  
#3 Posted : Tuesday, August 1, 2023 2:11:12 PM(UTC)
Khushii

Rank: Newbie

Groups: Registered
Joined: 7/26/2023(UTC)
Posts: 4
Canada

Thanks: 2 times
Thanks, I tried changing the session timeout and it worked !
OrkMan  
#4 Posted : Tuesday, September 12, 2023 8:20:22 AM(UTC)
OrkMan

Rank: Newbie

Groups: Registered
Joined: 9/12/2023(UTC)
Posts: 0

We are using a similar setup for real time data, and we are getting the same error message after about 24 hours ("The report is not in your session anymore"). For some reason there are no ASP option in IIS, and we tried changing the appsetting.json "SessionTimeout" value to 10080, but it didn't help us sadly.

I'm seeing events like this in the event viewer:
"A worker process with process id of '29604' serving application pool 'Seal Application Pool' was shutdown due to inactivity. Application Pool timeout configuration was set to 20 minutes. A new worker process will be started when needed."

The reports work fine after 20 minutes, so we are not sure, if this is the cause of the error. Any advice? Thanks!
epf  
#5 Posted : Tuesday, September 12, 2023 8:39:06 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 1,208
Switzerland

Thanks: 14 times
Was thanked: 205 time(s) in 198 post(s)
At least configure your application pool 'Idle time-out' to a big value
You may also to change the application pool Recycling: try to set 'Regular Time Interval' to 0
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.