logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
div  
#1 Posted : Wednesday, January 20, 2021 10:00:16 AM(UTC)
div

Rank: Newbie

Groups: Registered
Joined: 1/13/2021(UTC)
Posts: 0
India
Location: Chennai

Thanks: 5 times
For last 4 days i'm trying to publish the report on IIS.

It's not working, I've installed IIS, I can run Hello World app on localhost but When i publish the report from Seal Server Manager, I only get this error message evey time.

I've read the Documents 3 times, I've done all the procedure. even though i'm not able to publish on IIS. It's not even publishing default report. I've tried with my personal datasource, sample datasource , northwind etc. None of those work.


I'm using No authentication.


Please help...

here is snapshot of localhost

[img=https://ramcocementso365-my.sharepoint.com/:i:/g/personal/hdivyeshkumarm_ramcoindtechserv_co_in/EVxf6T1Gy5xCkowTXXUVZ4MBCzSE8VBbMb2KeQWtArO4VQ?e=WAYoVC]IIS error[/img]
epf  
#2 Posted : Thursday, January 21, 2021 3:49:42 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 1,011
Switzerland

Thanks: 14 times
Was thanked: 173 time(s) in 167 post(s)
check you have installed IIS with the ASP.Net feature
then be sure to run the Server Manager as Administrator when publishing the site
div  
#3 Posted : Monday, January 25, 2021 11:33:22 AM(UTC)
div

Rank: Newbie

Groups: Registered
Joined: 1/13/2021(UTC)
Posts: 0
India
Location: Chennai

Thanks: 5 times
I've Installed IIS with ASP.Net features. I can run website/publish other things on localhost . but only sealreports won't publish.

I'm running the Server Manager as Administrator and also configured the server security, for personal dashboard and default dashboard both.
When i try to publish personal dashboard i'm also getting same error.


Here are my configuration for server, i'm using integrated windows authentication
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
Security Group: Group
View Type: View reports and dashboards
Personal Folder: Personal folder for reports and files
Show all folders: no
Dashboard Personal View: yes
Dashboard Personal Folder: yes
SQL Models: no
Widget Publication: yes
Dashboard Folder:'BikeStore' => Right:View dashboards
Widget:'Report Name:BikeStore.srex; Widget Name:Bike Store Widget; Tag:Group' => Right:Can be selected
Folder:'\VSIncludePro' => Right:Execute reports and outputs / View files; Use Sub-folders:Yes; Manage Sub-folders:Yes; Files Only:No
&&&&&&&&&&&&&&&&&&&&&&&&&&



And this is the Error I'm getting when i publish on IIS
&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information:
Module IIS Web Core
Notification Unknown
Handler Not yet determined
Error Code 0x8007000d
Config Error
Config File \\?\C:\inetpub\wwwroot\Seal Report\web.config
Requested URL http://localhost:80/
Physical Path
Logon Method Not yet determined
Logon User Not yet determined

Config Source:
-1:
0:



&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&

Please Help??

Web publishing of dashboard created in local windows app, is included in free software right? because that's what I'm tying to do here.
div  
#4 Posted : Monday, January 25, 2021 12:52:34 PM(UTC)
div

Rank: Newbie

Groups: Registered
Joined: 1/13/2021(UTC)
Posts: 0
India
Location: Chennai

Thanks: 5 times
IGNORE PREVIOUS POST BY ME

OK, Somehow by Miracle, the web publishing started after I deleted the Seal Report Folder from IIS root directory in C drive. and website also showring the the directory of all reports.
But when i click on report to view it. It opens the new tab and shows this error Message

&&&&&&&&&&&&&&&&& -- START OF ERROR
Sorry, we got an unexpected exception.
Please consult log files on the server machine to have more information (Logs Repository folder and Windows Event Logs on Windows machine)...
&&&&&&&&&&&&&&&&&&&&&&&& -- END OF ERROR

And When I check the logs

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&& -------START OF FILE
**********
1/25/2021 6:19:44 PM Error
Unexpected error:

Access to the path 'C:\Windows\TEMP' is denied.
( at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileSystemEnumerableIterator`1.CommonInit()
at System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost)
at System.IO.Directory.GetDirectories(String path, String searchPattern)
at Seal.Helpers.FileHelper.PurgeTempApplicationDirectory()
at SealWebServer.Controllers.HomeController.initReportExecution(Report report, String viewGUID, String outputGUID, Boolean toResult)
at SealWebServer.Controllers.HomeController.SWExecuteReport(String path, Nullable`1 render, String viewGUID, String outputGUID))

User: ''; Groups: 'Group'; Windows User: 'NT AUTHORITY\IUSR'
URL: 'http://localhost:80/SWExecuteReport'
Session: 'ikpbo54uaoz5a2hvefudwreh'
IP: '::1'
path=\BikeStore.srex
render=false
viewGUID=
outputGUID=

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&& - END OF FILE


Please Help

epf  
#5 Posted : Monday, January 25, 2021 1:22:52 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 1,011
Switzerland

Thanks: 14 times
Was thanked: 173 time(s) in 167 post(s)
It looks like you are using Windows User: 'NT AUTHORITY\IUSR' to publish your Web Site.
And this user has no right for the Windows\Temp directory.
thanks 1 user thanked epf for this useful post.
div on 1/27/2021(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.