logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
JohnChen  
#1 Posted : Tuesday, November 10, 2020 6:55:32 AM(UTC)
JohnChen

Rank: Newbie

Groups: Registered
Joined: 10/26/2019(UTC)
Posts: 9
China
Location: China

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
Hi,

I have a report which is running fine in report designer. But it's not working in Web.

The error message:

Error detail:
Error opening database connection:
Cannot open database "DBPROD" requested by the login. The login failed.
Login failed for user 'NT AUTHORITY\SYSTEM'.
14:24:47 Model 'Model': Building pages...
14:24:47 Model 'Model': Building tables...
14:24:47 Model 'Model': Building totals...
14:24:48 Rendering report...

According to other post, I have created system DSNs. I am using Windows 2012 and DB is MS SQL 2014. The report is based on SQL accounts (sa).

Any hints?

Thanks.
epf  
#2 Posted : Tuesday, November 10, 2020 11:08:13 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 961
Switzerland

Thanks: 14 times
Was thanked: 161 time(s) in 155 post(s)
it is probably due to the security applied to connect to your database.
depending on the authentication you have used in IIS, the user may be different to access the database (e.g. user defined in the application pool)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.