logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
manojmat  
#1 Posted : Thursday, February 6, 2020 3:59:54 AM(UTC)
manojmat

Rank: Newbie

Groups: Registered
Joined: 2/6/2020(UTC)
Posts: 2
India
Location: Mumbai

Thanks: 1 times
First of all, thanks for this excellent reporting tool. I usually provide reporting solutions using Jaspersoft for clients. Was very impressed with the rendering of charts and responsive reports in Seal.

My issue is with html format emails in v5.1. Tried sending some samples including the simple product list in html format with default options (with html result in email body set) but though the entire html is sent in the raw message, only the heading, logo and a button called 'Toggle Navigation' is visible in gmail and yahoo web interface. Tried older versions and it's only working well if I go down to v3.4. html mails are correctly sent with default options in v3.4. Charts were not visible though, but everything else works. Tried sending the 3.4 repository report with 5.1 designer and it still doesn't render correctly in email. Can't send 5.1 report with 3.4 designer.

Are some changes required to get the html email working properly? I tried setting custom format to html print and turning off the responsive setting for bootstrap but that didn't work either.
epf  
#2 Posted : Thursday, February 6, 2020 7:50:48 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 852
Switzerland

Thanks: 14 times
Was thanked: 148 time(s) in 142 post(s)
Thank you for your feebacks, I will check the HTML by email and come back to this point...
epf  
#3 Posted : Friday, February 7, 2020 10:07:06 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 852
Switzerland

Thanks: 14 times
Was thanked: 148 time(s) in 142 post(s)
I made a test, and yes you have this 'Toggle Navigation' button when you use gmail web site...
it is weird as it looks like gmail disable/modify the javascript of the page renderer, I did not understand why it does this in version 5 and not in 3.4, perhaps because of the use of bootstrap 3....
however if you use download link and view the file it works fine.
manojmat  
#4 Posted : Friday, February 7, 2020 10:19:11 AM(UTC)
manojmat

Rank: Newbie

Groups: Registered
Joined: 2/6/2020(UTC)
Posts: 2
India
Location: Mumbai

Thanks: 1 times
It's not only with gmail, same issue with yahoo and I suspect with every other webmail. Did not check in Outlook or other clients. Yes, the html file renders correctly in the browser. I suspect html email is more restricted in what controls and scripts are supported and the new framework view does not play well with that. Any hope for an html email friendly option?
epf  
#5 Posted : Friday, February 7, 2020 10:25:57 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 852
Switzerland

Thanks: 14 times
Was thanked: 148 time(s) in 142 post(s)
no, it might be specific per webmail apps , it works fine with Outlook fat client,
the workaround to download the document works fine, it is just an extra click...
you can continue your investigations if you wish and hopefully find and share a solution.
thanks 1 user thanked epf for this useful post.
manojmat on 2/7/2020(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.