logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
abbey  
#1 Posted : Thursday, March 19, 2020 9:52:49 PM(UTC)
abbey

Rank: Newbie

Groups: Registered
Joined: 3/19/2020(UTC)
Posts: 2
Canada

Hello!

At my workplace, we are attempting to use the SEAL reporting tools to connect to a local SQL Server data source installed as a named instance, which is to say it needs to be named in the connection string rather than just '.' or any other default description.

The server manager has no trouble with this. The following connection string was generated by its integrated connection string wizard, and successfully connects in the server manager:

Quote:
Provider=SQLOLEDB.1;Persist Security Info=True;Initial Catalog=MarineLMS_Trunk;Data Source=ABBEY-PC\SQL2012


However, any attempt to load this data source in the Report Designer causes the Designer to go into a recursion loop, not visibly loading at all until it is forcibly terminated by the OS with a stack overflow error.

Experimentation on my part showed that the problem seems to be the backslash character. Seemingly when that is present in the connection string (I have not tested it elsewhere in the .scfx file) then when the Report Designer loads it, it goes into a recursion loop. However, there does not appear to be any way to specify the name of the data source, because SQL Server requires this format for named instances.

Is there a solution for this? This is a common configuration for SQL server and one that is absolutely necessary for us.

-- Abbey
epf  
#2 Posted : Friday, March 20, 2020 7:22:31 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 880
Switzerland

Thanks: 14 times
Was thanked: 150 time(s) in 144 post(s)
Hi, this error is strange and we never experienced it...even if we used often SQLServer named instance.
Which version of Seal Report are you using ?

Perhaps you can use another driver to see if it changes: Provider=SQLNCLI11.1;Persist Security Info=False;Initial Catalog=testdb;Data Source=ariacomepp5\sqlexpress;Initial File Name="";Server SPN=""

The version 5.5 (coming soon) will offer native SQLServer driver or ODBC connection instead of OLEDB, but not sure it will solve your problem...
abbey  
#3 Posted : Friday, March 20, 2020 4:11:01 PM(UTC)
abbey

Rank: Newbie

Groups: Registered
Joined: 3/19/2020(UTC)
Posts: 2
Canada

Version 5.1.2.0 as far as I can tell. This bug is very consistent.

Per your suggestion I have now tried it by generating a connection string for a different driver. The new connection string is:

Quote:
Provider=SQLNCLI11;Persist Security Info=False;Initial Catalog=MarineLMS_Trunk;Data Source=ABBEY-PC\SQL2012;Initial File Name="";Server SPN=""


This displays exactly the same behavior: server manager works fine, connection tests correctly, report designer goes into a recursion loop and overflows the stack.
epf  
#4 Posted : Wednesday, March 25, 2020 4:46:32 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 880
Switzerland

Thanks: 14 times
Was thanked: 150 time(s) in 144 post(s)
Can you send me your datasource file so I may reproduce the problem....
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.