logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
j.torres@tewis.com  
#1 Posted : Friday, May 31, 2019 8:18:00 AM(UTC)
j.torres@tewis.com

Rank: Member

Groups: Registered
Joined: 4/7/2019(UTC)
Posts: 21
Spain

Thanks: 6 times
Hello. When a scheduled report is executed to a folder output, the server console shows theses messages:

Please clean 'C:\Users\myUser\AppData\Local\Temp\RazorEngine_jp2kwji4.o12 manually!
Please clean 'C:\Users\myUser\AppData\Local\Temp\RazorEngine_rsdtyhdg.g4d manually!
....
continually

What does it mean? The execution of the report has taken so much time than when executed manually. Is it normal?

Thanks in advance.


epf  
#2 Posted : Saturday, June 1, 2019 6:08:59 AM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 653
Switzerland

Thanks: 9 times
Was thanked: 111 time(s) in 108 post(s)
This comes from the RazorEngine (check https://github.com/Antaris/RazorEngine/issues/244)
The files are actually the compiled assemblies of all your scripts used to execute a report.

Seal Report will cleanup unused files older than 2 hours...and most of the script assemblies are cached so it should not be an issue.
This will be enhanced in the 5.0.

When executing through the Scheduler, all the assemblies have to be recompiled for the first execution...so it takes a bit time (same time as when you execute a report with a new instance of the Report Designer).

Edited by user Saturday, June 1, 2019 8:10:17 PM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.